every 3hrs wind refresh
Post by iconPost by ANZOR | 2017-10-22 | 19:55:43

Hey zezo was wondering if it has any effect that the wind is changing every 3 hours on your site and in game every 1 hour,becuase i am following your route right now and by the degree i am following it says that my boat should go 12.36 kts and its actually going 12.9 kts,so i was just wondering if the weather is affecting the speed

commenticon 5 Comments
Post by iconPost by zezo | 2017-10-22 | 20:12:56
The wind changes every 3 hours only for the wind display - I'm not sure how to implement a good control knob for 10-minute increments.

The info at the black dot popups is exact down to +/- 10 minutes. Also, the "Now" switch is interpolated between the 3-hour data.

There are 4 possible sources of error:

1) Most obvious - you don't have the "pro sails" box checked if you have them in the game or vice versa.

2) The router works in 10-minute steps, so if the weather changes rapidly those 5 or 7 minutes may be visible.

3) VR does some kind of interpolation between the old and new forecast for the first data point. I use the old data for 1.5 hours and then the new data. Again, this is visible if the new GFS model is quite different, but the usual difference is at most 2-3 degrees.

4) Or it should probably be #1 The foils are not implemented server-side, so your boat speed on screen is not the same as the speed at which the server moves the boat. Can also be seen if you check your boat from another boat's point of view. I'm trying to stay as close as possible to the server-side view, even at the price of players complaining of speed differences between the router and the game.
Post by iconPost by zezo | 2017-10-22 | 20:17:59
Oh, and now and then the things get plain out of sync - weather gets delayed at NOAA or someone at VR screws up some script or my internet connection or power go down for an hour.

It's rare - like once in a month or so, but you should keep it in mind and keep an eye on wind speed and direction in both places.
Post by iconPost by ANZOR | 2017-10-22 | 20:35:03
oh okay thanks for the answer i was just wondering if its something up with me,but i checked everything now it got back to normal speed of the boat should be 12.4 and i am going 12.4,but i was afraid something went wrong with the router so i contacted you i am glad i can calmly follow the route again and know there are no problems in it,again thanks for answering ;)
Post by iconPost by zezo | 2017-10-22 | 20:58:03
That's actually a good idea, because I can't always follow my own advice and keep everything under control, so it's good to have a game status posted, even if it means occasional false alarm.
Post by iconPost by fadoue | 2017-10-22 | 21:17:16
Thanks for all Cvetan !
border
Topics list
Posts
border
48
border
border
12
border
border
52
border
border
27
border
border
60
border
border
7
border
border
26
border
border
53
border
border
42
border
border
12
border
border
5
border
border
Copyright 2009 by ZEZO.ORG. All Rights Reserved.